Depreciation Notice Error in Phpmyadmin With Ubuntu16.04

If you see the error notice properly you can understand what does it means. This error notice means some of your PHP has old constructors. So if you replace these old constructors with new constructor then the problem will be solved.

Depreciation Notice Error in Phpmyadmin With Ubuntu16.04

 

To do this, open streems.php file by this command.

sudo gedit /usr/share/php/php-gettext/streams.php

 StringReader Error: To find it go to line number 52 then

//Replace this line
function StringReader ($str='') {

//with
function __construct($str='') {

 

FileReader Error: To find it go to line number 90 then

//Change this
function FileReader ($str='') {

//To
function __construct($str='') {

 

CacheFileReader Error: To find it go to line number 146 then

//Change this
function CacheFileReader ($str='') {

//To
function __construct($str='') {

Then save & close the file. After that open gettext.php file by this command.

sudo gedit /usr/share/php/php-gettext/gettext.php

Go to line number 101 then

// Replace this line
function gettext_reader($Reader, $enable_cache = true) {

//With
function __construct($Reader, $enable_cache = true) {